Problem bei Failsafe über SUMD

Soundmodul für Fahrgeräusche (speziell für RC-Modelle). Der Nachfolger des USM-RC-2
Antworten
Benutzeravatar
Werner_Fly
Beiträge: 138
Registriert: So 26. Jan 2020, 13:02

Problem bei Failsafe über SUMD

Beitrag von Werner_Fly »

Hallo,

ich knabbere schon einige Zeit an diesem Problem rum, finde aber keine wirkliche Lösung dazu.
Daher jetzt mal die Bitte an Euch zur Unterstützung – schon mal DANKE im Voraus!

Das Problem besteht beim RC-2 und dem RC-3, ich schreibe das mal hier beim RC-3.

Hintergrundinfo

Ich betreibe das Sound-Modul in meinem großen Doppeldecker. Gesteuert wird das Modul über SUMD-OF-16 von einem Rx-Type gr-18 (Graupner / Hott, Tx ist eine mc-28).

Super von Beier, dass die Möglichkeit zur Nutzung von SUMD besteht - vielen Dank!

So spart man sich die gesamte Verkabelung der einzelnen PWM-Kanäle RX => Modul und kann gleichzeitig auch noch unter den 16 Tx-Kanälen die benötigten bzw. verfügbaren im Modul frei auswählen, ohne dass man diese Kanäle am Rx physikalisch verfügbar haben müsste. Das geht also auch für Rx mit sehr begrenzter Anzahl von Servo-Ausgängen.

Bei mir liegen die meisten Prop-Kanäle im Tx im oberen Bereich, da ich größere Modelle immer mit Rx-Redundanz (hier 2x gr-18 über SUMD mit PowerExpander SRS) fliege. Die Gyro-Funktionen dieser Rx zur Fluglagenstabilisierung setzen eine feste Kanalbelegung im unteren Bereich voraus, Kanal-Mapping ist daher auch nur sehr eingeschränkt möglich.

Im Flugmodell wir i. d. R. die maximale Soundleistung benötigt, was zu einer nicht unerheblichen Erwärmung von elektronischen Komponenten im Modul führt. Während des Flugs besteht forcierte Kühlung (Fahrt- und Propellerwind), nach der Landung fällt die aber sofort vollständig weg und die Temperatur steigt weiter an.

Ich habe daher einen Lüfternachlauf nach Abschalten des Fahrsounds mit zusätzlicher Sprachansage realisiert.

Mit Beginn des Nachlaufs erfolgt eine Sprachausgabe „Start Nachlaufzeit, System noch nicht abschalten“. Damit in der Folgezeit dann meine grauen Zellen am Flugplatz nicht vergessen, dass das komplette Fernsteuer- und Soundsystem noch eingeschaltet sind, erfolgt alle 15 sec eine dezente Tonausgabe. Am Ende dann der Hinweis „Ende Nachlaufzeit. Systeme ausschalten.“

Das lässt sich auf verschiedenen Wegen realisieren. Ich habe den Weg über das Abstellgeräusch gewählt, was beim Abschalten des Fahrsounds (bei mir über einen Schalter vom Tx) ja automatisch läuft. Das Abstellgeräusch aktiviert über einen Schaltaus- und Eingang dann den o. g. Info-Sound zum Nachlauf und damit gleichzeitig auch den Lüfter in dieser Zeit.

Nun der Störenfried: Failsafe bei laufendem Fahrsound

Zwar können die Prop-Kanäle der Module über SUMD gesteuert werden, aber leider wurde die SUMD-Funktionalität nicht vollständig implementiert. Es gibt keine Möglichkeit, Failsafe-Positionen im Modul abzulegen. Stattdessen laufen alle Prop-Kanäle in den Bereich „N“, dieser Bereich kann aber nicht ausgewertet werden für Steuerungsaufgaben.

Bei mir steht für „Fahrsound ein“ der Prop#3 im Bereich „D“.
Mit auftretendem Failsafe wechselt der Wert nun automatisch in den Bereich „N“. Damit wird der Fahrsound zwangsweise ausgeschaltet.

Das wiederum hat zur Konsequenz, dass der Sound für den Nachlauf gestartet wird – was hier natürlich völlig unsinnig ist.
Man hört nun zwei Ansagen gleichzeitig: den Warnhinwies, dass Failsafe aufgetreten ist und gleichzeitig den Nachlauf-Sound.

Ich hatte auch schon andere Verfahren zum Start des Nachlauf-Sounds getestet, komme aber an dem Failsafe-Problem einfach nicht vorbei.

So, dann hoffe ich, dass kompetente und stets so freundlichen Forumsmitglieder es besser können als ich.

Noch mal danke im Voraus.

Grüße
Werner


Übrigens

Man kann nun lange darüber diskutieren, ob solche Ansagen notwendig sind oder nicht.
Klar, der Flieger fliegt auch ohne die – aber die Ansagen erzeugen Begeisterung bei mir (Failsafe als solches natürlich nicht …) und stellen Herausforderungen bei der Umsetzung da, das brauchen wir Modellbauer doch, oder?!

Die auftretenden Temperaturen gefährden bei mir nicht (!) die Elektronik, zumal die ICs über interne Temperatur-Abschaltungen verfügen. Ich habe am Kühlkörper beim RC-2 knapp über 70 Grad (ruhende Luft ) gemessen, dort fasse ich dann nicht mehr hin.
Da schlägt dann vermutlich meine frühere Berufstätigkeit im Bereich professioneller Systeme hoher Zuverlässigkeit und langer Lebensdauer durch und erzeugt „mentales Unwohlsein“ … ;)
Modellflieger aus Leidenschaft - schon über 60 Jahre!

https://vimeo.com/56821772
https://vimeo.com/356373438
Antworten