SM IR Schaltfunktion der Servoausgänge

Infrarot Lichtmodule für die Soundmodule USM-RC und USM-RC-2
Benutzeravatar
airknee
Beiträge: 400
Registriert: So 25. Jan 2009, 11:35
Wohnort: Fontanestadt Neuruppin

SM IR Schaltfunktion der Servoausgänge

Beitragvon airknee » Mo 7. Jun 2010, 13:51

:D Hallo BEIER Team und hallo Modellbaufreunde,

es ist Zeit mal wieder was anzufragen.... ;) Da ich ja wie viele andere stolzer Besitzer des SM-IR 16 bin :mrgreen: und es ausgiebig testete, ist mir eine Sache aufgefallen die mich mein gesamtes Weekend kostete und

etliche meiner ohnehin schon knapp vorhandenen Haare. Ich erläutere das Szenario:

Ich habe einen Tiefbettauflieger, welcher über 2 Auffahrrampen verfügt, die elektrisch angetrieben auf- und abfahren können. Dieses geschieht mit einem Getriebemotor, der über eine quer eingebaute Drehachse 2 Hebel bewegt,

die gegen die Auffahrrampen drücken. Ganz simpel. Nun muss der Getriebemotor "stufenlos" angesprochen werden, um die beiden Hebel in jegliche Position stellen zu können.

Ich dachte mir folgendes: Wenn das IR-Modul ein Servo

stufenlos regeln kann über den Nautic Modus, so kann ich doch anstelle dessen einen Fahrtregler anschließen. Das dachte ich. Denn ein Servo kann ja auch in jeder (fast jeder) Position angehalten werden. So BEIER und so auch

beim Testen. Ich kaufte bei Herrn Aichtal einen Thor 15 Regler mit Servofunktion. Ich probierte erst einmal ohne die Servofunktion. Also Regler an den Servoausgang 1 oder 2 beim Modul und dann testen. Aber nix da........ :(

Der Regler steuert zwar in eine Richtung beim Schalten mit dem Nautic Multiswitschmodul, aber der hält einfach nicht an. Nur wenn ich am Schalter die entgegengesetzte Richtung schaltete, dann blieb er zwar nicht stehen

sondern kehrte lediglich die Drehrichtung um. Das war schon komisch. Warum funktioniert das mit dem Servo und einem Regler nicht??????????? Ich hatte erst einmal keinen blassen Schimmer.

Dann dachte ich mir.....Hmh :? da ist doch ein Poti am Regler. Im Prinzip soll der Regler einfach ein Servo mit Leistungselektronik sein. So der Plan.Aber auch beim Probieren damit hatte ich Probleme. Er ließ sich einschalten aber

er schaltete nicht ab, egal was ich am Sender auch für Experimente veranstaltete. Schalte hoch runter doppelt und dreifach aber nix da.....Es passierte maximal eine Drehrichtungsänderung. Und hätte ich keinen Endlagenschalter

so würden meine Zahnräder Beifall klatschen. So stand ich da und kam auf nix. Ein Servo geht einwandfrei zu bewegen und der Regler mit Poti machte keine Anstalten zu gehorchen. Jetzt meine Fragen: Ist es so, dass ich beim

Schalten der Servoausgänge lediglich die Impulsbreite verschiebe????? Also den Punkt? Es gibt keine klassische Mittelstellung bei bspsw. 1,5ms??????? Muss ja so sein oder? Denn das Servo gleicht sich ja durch den Poti selbst aus.

Das ist erst einmal meine Vermutung. Dann haben wir hier alles ausprobiert, Den Regler rausgeschmissen und anstelle desse eine Servoelektronik installiert. Den Poti auf die Drehachse und es sollte gehen.

Dachten wir. Aber auch das funktionierte einfach nicht. Ich habe keine ahnung warum das so nicht geht......Also alles ab und Servo ran. Das ging. :shock: Was soll das Problem sein :?: Ich schaute mir den

kleinen Getriebemotor an und dort waren lediglich 2 Enstörkondis angelötet. Und an jedem Pol des Motors war ein Widerstand vorgelötet. Vor einem Pol war zusäzlich lediglich ein Mikrotaster mit einer Diode

wegen der Endabschaltung angebracht. Nun Ich lötete die Servoelektronikmotorausgänge ohne Umwege direkt an den Getriebemotor.Natürlich habe ich alles vorher angelötete entfernt.

Und das Poti kam an die Drehachse. Mit einmal funtionierte es. Ich verstand die Welt nicht mehr. Wie können diese Bauteile Auf das Regelverhalten Einfluss nehmen :?: :?: :?: MIr ist auch aufgefallen,

dass am IR Modul beim Probieren die Grüne LED erlosch aber die Rote LED fleißig weiterblinkte.

Und wenn über die angeschlossene Servoelektronik der Motor begann zu drehen, dann wurde die Blinkfrequenz der roten LED plötzlich um die Hälfte langsamer. :? :? :? Ich war erst einmal überfordert. Und musste Schluss machen.

Der Akku war ein 6Zeller NiMh und kann eventuell nicht mehr der vollste gewesesn sein. Kann das denn der Grund für das Erlöschen der grünen LED sein?

Und warum veränderte sich die Blinkfrequenz des IR Moduls um die Hälfte? Das ist ne Menge ich weiß, aber wir haben ja Zeit......... :mrgreen:

Ich hoffe auf euch viele Grüße der Airknee ;)
Gruß der Airknee :)

Benutzeravatar
BEIER-Electronic Andy
Administrator
Beiträge: 2805
Registriert: Mi 17. Dez 2008, 07:37

Re: SM IR Schaltfunktion der Servoausgänge

Beitragvon BEIER-Electronic Andy » Di 8. Jun 2010, 14:03

Hallo airknee,

die Servoausgänge des SM-IR-16 bringen (wie jeder übliche Empfängerausgang auch) einen Impuls, mit einer Länge von 1,0 - 2,0ms heraus. Die Abstufung dabei sind 200 Schritte (0,005ms). Der Servoausgang kann also auch auf eine Impulslänge von 1,500ms gestellt werden. Dies entspricht ja normalerweise der Neutralstellung und ein Fahrtenregler, der auf diese Neutralstellung programmiert ist, müsste den Motor bei dieser Stellung auch abschalten.

Den Thor 15 Regler mit Servofunktion kenne ich jetzt nicht, kann deshalb auch nicht sagen, warum der Regler die Neutralstellung nicht erkennen sollte.

Die grüne LED auf dem Modul hat keine spezielle Funktion. Sie blinkt beim Einschalten paar mal und soll dann einfach nur dauernd leuchten. Per Software wird die LED jedenfalls nicht ausgeschaltet. Daher kann ich nur vermuten, dass das eine Störung war (eventuell durch einen leeren Akku?).

Das langsamere Blinken der roten LED, ist etwas mysteriös :?
Auch das kann eigentlich nur eine Störung von der Servoelektronik/Motor sein - oder aber hervorgerufen durch Spannungseinbrüche auf der Akkuspannung bzw. der internen Spannung auf dem Modul.

Wie läuft denn die Spannungsversorgung der "Servoelekronik"? Alles über den 3pol. Servostecker? Oder ist der Pluspols, wie in der Anleitung auf Seite 8 gezeichnet, direkt mit dem Akku verbunden?

Bei einem zu hohen Strom über den 3pol. Servoanschluss, könnte ich mir nämlich am ehesten solch komische Effekte, wie die geänderte Blinkfrequenz, oder ein Ausgehen der grünen LED erklären.

Benutzeravatar
airknee
Beiträge: 400
Registriert: So 25. Jan 2009, 11:35
Wohnort: Fontanestadt Neuruppin

Re: SM IR Schaltfunktion der Servoausgänge

Beitragvon airknee » Di 8. Jun 2010, 16:56

:) Hallo Team, danke erst einmal

soweit habe ich alles verstanden, nur eine Frage vorweg:

Wie ist es möglich dem SM IR mitzuteilen, dass es bei 1,5ms stehenzubleiben hat beim Schalten :?:

Es ist mir bisher nicht gelungen (auch bei eingestellter maximaler Zeitverzögerung) irgendwie einen Punkt zu finden, welcher etwa die Mitte darstellt.

Es gibt ja keinen Anhaltspunkt (optisch oder elektronisch) der mir zeigt oder mich erahnen lässt wo ich mich gerade befinde. Da es ja stufenlos zu schalten ist, habe

ich noch keine Idee was ich ändern kann.

Wenn ich am Multiswitch schalte, dann weiß ich nicht wie lange ich schalten muss bis ich eine bestimmte Position erreiche. Mal passt es ganz knapp mal gar nicht und so weiter.

An sich nicht schlimm, aber in der Summe sehr schade.

Und ja: Der Getriebemotor am Servomotorausgang hat wohl zuviel Strom verbraucht über das Servoanschlusskabel. Der Motor hat über das SM-IR den Strom gezogen und nicht über den Akku direkt.

Das ändere ich sofort. Nur noch eines:

Habt Ihr eine Idee warum der Mikrotaster mit Diode (Endlagenschalter) und die Widerstände ein Problem sind? Denn ohne diese Bauteile hält mit aufgestecktem Poti auf der Drehachse der Motor auch an, wenn ich schalte über den

Multiswitch. Ich habe selber noch keine Erklärung für das Phänomen.

Ich habe noch den Schaltbaustein von euch zu liegen Schaltmodul SM-2-4Q ist es möglich, dass ich mit den Motorausgängen einer Servoelektronik den Baustein zum Schalten bringen kann?

Wenn er doch Minusschaltend ist, dann dreht sich doch auch Plus und Minus an den Motorausgängen der Servoelektronik um oder irre ich da? Dann könnte man doch den einen oder den anderen Eingang am Schaltbaustein auslösen?

Das wäre sowieso besser als ein Regler, da bei Verzögerung ( Einstellung am SM-IR) der Regler erst 'ne Weile braucht, um genug Spannung zu schalten und er ganz langsam anfährt. Das ist ein Nachteil meiner bisherigen Testerei.

Für heute reicht es erst einmal.....Viele Grüße der Airknee :D
Gruß der Airknee :)

Benutzeravatar
BEIER-Electronic Andy
Administrator
Beiträge: 2805
Registriert: Mi 17. Dez 2008, 07:37

Re: SM IR Schaltfunktion der Servoausgänge

Beitragvon BEIER-Electronic Andy » Mi 9. Jun 2010, 15:10

Den Servoausgang des SM-IR-16 auf (möglichst exakt) 1,500ms zu stellen, ist über die Nautic-Schalter leider praktisch so gut wie nicht möglich. Das liegt vor allem an der Verzögerung, die die Nautic-Übertragung ja leider hat. Auch wenn man den Schalter nur kurz antippt, läuft der Servo dann ja für mind. 200ms in eine Richtung, und das sind dann eben immer mehrere der internen 200 Schritte (á 0,005ms). Ist alles natürlich auch abhängig davon, welchen Bereich der Fahrtregler denn als Neutralstellung zulässt. Ist dieser Bereich sehr klein, ist es sicher kaum möglich, den Punkt dann überhaupt zu treffen.

Zu der Servoelektronik und dem Mikrotaster mit Diode und den Widerständen, kann ich leider gar nichts sagen. Da müsste man sich erst mal ausführlich in die ganze Schaltung einarbeiten (wo ist was angeschlossen? wie funktioniert der Regelkreis?, usw.)

Das Schaltmodul SM-2-4Q über eine Servoelektronik anzusteuern, könnte eventuell klappen... Aber auch hier ist es unmöglich eine Prognose abzugeben, was der Motor dann wirklich macht, bzw. ob der ganze Regelkreis der Servoelektronik überhaupt noch sinnvoll funktioniert. Aber versuchen kann man es ja mal :mrgreen:


Zurück zu „SM-IR-16 und SM-IR-16-2“



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast